Устройство удаленного управления розетками

Устройство удаленного управления розетками

Два года назад я приобрел на дачу NetPing 2/PWR-220 v3/ETH – устройство удаленного управления розетками питания 220В по сети Ethernet. Устройство понравилось простотой настройки и многофункциональностью.
>"/>
Этакий на все руки мастер (картинка для привлечения внимания).

Итак, встречайте. Герой сегодняшнего обзора
NetPing 2/PWR-220 v3/ETH

  • 2 независимые управляемые электрические розетки 220 вольт.
  • Суммарная мощность нагрузки до 1000 ватт, с произвольным распределением мощности нагрузки по двум каналам.
  • Управление через собственный web-интерфейс, и по протоколу SNMP.
  • Функция «сторожевого таймера» (watchdog), позволяющая автоматически производить перезагрузку подключенного оборудования по питанию в случае его «зависания» или по заранее составленному расписанию.
  • К устройству можно подключить ряд датчиков для удаленного мониторинга: датчики температуры, наличия напряжения в сети 220 вольт, открывания двери, протечки, задымления и т.п.
  • Встроенный Ethernet switch на 2 порта

На Хабре уже был обзор похожего устройства UniPing RS-232. Поскольку принципы и интерфейсы у них практически идентичны, сосредоточусь на практических примерах применения устройства.

1. Internet watchdog

Изначально NetPing приобретался для перезагрузки роутера со вставленным в него и регулярно зависающим модемом от SkyLink. С поставленной задачей устройство справилось прекрасно. Работает по принципу «поставил и забыл».
Настраивается вполне не сложно. Сначала в разделе «Сторож» выставляем:
>"/>
Потом в разделе «Управление 220V» выбираем режим «Сторож».
>"/>
После чего NetPing регулярно пингует указанные в найстройках ip-адреса и, в случае их недоступности, на секунду снимает напряжение с розетки.
Факт перезапуска, что приятно, фиксируется в логе NetPing.

2. Включение нагрузки по расписанию

Весной и вначале лета приводил в порядок дренажную систему вокруг подвала. Проблема заключалась в малом объеме накопительного колодца и слишком длинной отводящей трубе, из которой после выключения насоса часть воды возвращалась обратно в колодец. В результате классическая система с поплавком практически не давала насосу остановиться. Ставить обратный клапан или еще как переделывать трубу не хотелось, т.к. система была временной. Тем не менее, нужно было дать возможность насосу отдыхать, но при этом не слишком долго, чтобы подвал не затопило.
Мне казалось, что расписание вида «включить на 10 минут в начале каждого часа» будет в самый раз. Но подключив насос к NetPing, и зайдя в веб-интерфейс понял, что количество включений/выключений по таймеру в день весьма ограничено.
>"/>
В розетках-таймерах, которые продают в окрестных магазинах, количество включений/выключений в день побольше, но тоже не 24. Что же делать.
Подождите, но ведь менять режим розеток в NetPing можно по сети с другого устройства… Берем следующий perl-скрипт.

Запускаем его на сервере с помощью cron: в 00 минут каждого часа включаем, через 10 минут выключаем. Готово!
Теперь розетку можно включать по любому, даже самому хитрому расписанию! В качестве сервера использовался NAS Synology DS411slim.
В логах NetPing отражает такую ситуацию как ручное включение/выключение нагрузки.
Особо порадовал запас по коммутируемой NetPing мощности. Все-таки насос потребляет 600Вт. За несколько месяцев работы проблем с этим не возникло.

3. Включение нагрузки по условию

На зиму поставил греющий кабель в трубу, идущую от колодца к дому. Первое время включал ее просто по таймеру на ночь, т.к. ночью, как правило, холоднее, плюс нет расхода воды, а значит замерзание наиболее вероятно.
Несколько раз приходили в голову мысли, что хорошо бы автоматически корректировать расписание исходя из температуры на улице, например, если мороз под -30, то пусть подогрев работает круглосуточно, а если оттепель, то подогрев можно и на ночь не включать. Правда, до реализации дело пока не дошло, но думаю, по аналогии с предыдущим примером все должно быть не сложно.
Зато дошли руки протянуть датчик температуры в подвал. Теперь можно настроить включение обогрева в зависимости от значения датчика температуры…
>"/>
Такой подход в теории выглядит идеально – греет только когда есть угроза замерзания. Однако меня терзают сомнения. Чтобы это гарантированно работало, датчик должен быть установлен в самом холодном (потенциально замерзающем) месте трубы. Однако, учитывая, что большая часть трубы лежит в земле, и к ней доступа уже нет, определить «самое холодное место» и установить туда датчик несколько проблематично. Так что окончательно перейти на автоматическое включение я пока не решился.

4. Датчики температуры

Помимо управления розетками NetPing также может работать с целым набором датчиков. На пробу я заказал несколько датчиков температуры.
Тут не обошлось без минусов:

  • Все датчики подключаются в одну колодку параллельно. Выглядит это как паук из проводов – никакой эстетики и удобства подключения.
  • Сама колодка требует специальной тонкой отвертки (некоторые производители в таких случаях включают отвертку в комплект поставки).
  • Датчики температуры подключаются с помощью четырех тоненьких проводов без разъема на конце. Если хочется нарастить кабель, нужно доставать паяльник.
  • NetPing хранит значение температуры как целое число, поэтому не зависимо от точности датчиков, получить можно только целые градусы. По большому счету в этом нет ничего страшного, просто графики часто получаются зигзагообразные: «19-20-19-20-19-20…»

Значения термо-датчиков можно увидеть на специальной странице в веб-интерфейсе NetPing.
>"/>
Программно можно получить значения датчиков по HTTP простым GET запросом или с помощью SNMP. Для примера ниже perl-скрипт для сохранения значения датчика температуры на cosm.com (ранее Pachube).

Результат работы аналогичного скрипта, вызываемого раз в минуту, можно посмотреть тут: https://cosm.com/feeds/83996

Обратите внимание! Зарегистрировавшись на cosm.com и написав несколько десятков строк кода мы:
— получили вполне удобный внешний интерфейс для NetPing в режиме «только для чтения» с графиками
— храним историю с интересующей нас частотой
— и самое главное(!) При аварии или пропадании связи мы знаем точное время аварии и значения датчиков на момент аварии! Как черный ящик у самолета!

5. Интеграция с системами домашней автоматизации

В данный момент NetPing скорее заточен под системы мониторинга серверной, чем под системы домашней автоматизации (нестандартные датчики, малое количество одновременно подключаемых датчиков, мало поддерживаемых типов датчиков). Однако сама идеология NetPing, когда датчики подключаются не напрямую к серверу, а к некому промежуточному устройству, которое в свою очередь подключается в общую Ethernet-сеть, мне кажется весьма правильной:

  • Датчики остаются простыми и дешевыми (как в 1-wire), но при этом в сети может быть более 1 мастера
  • Можно расположить устройство или несколько устройств поближе к датчикам – более простая топология сети, меньше ограничений на длину провода от датчика до устройства.
  • Выше отказоустойчивость и легче диагностика (каждый куст работает независимо).
  • Простую логику (если холодно, то включить обогрев) можно опустить на уровень контроллера и не занимать этим сервер домашней автоматизации, но при этом сохраняется возможность интеграции в общую систему.
  • За исключением датчиков температуры, мало какие датчики выдают непосредственно измеряемое значение. Как правило, они выдают напряжение или силу тока. Конвертация измеренного значения в нужные единицы, как раз работа для контроллера (устройства наподобие NetPing).
  • Еще одной хорошей идеей, реализованной в NetPing, мне кажется встроенный Ethernet switch. Что позволяет воткнуть устройство в любую Ethernet –розетку, даже если она занята. Ведь сколько ни закладывай запасных проводов, а в нужном месте все равно одного порта не хватит.

Конечно, можно взять промышленный PLC и подключить датчики к нему. Но там и уровень цен другой, и устроено все зачастую чересчур сложно для домашней автоматизации.

Перейдем от теории к практике. Недавно тестировал систему домашней автоматизации openhab. В ней заявлена поддержка SNMP, но только с помощью TRAP (GET и SET не поддерживаются). Для датчиков температуры этого оказалось достаточно.
a) В разделе «Настройки» указываем «сервер для посылки Trap сообщений»…

Читайте также:  Ситцевые шторы на кухню

b) А в разделе Термодатчики -> «посылка trap сообщений» указываем «период посылки» 60 сек.
>"/>
c) В openhab заполняем конфигурационные файлы.
NetPing раз в минуту отправляет TRAP — openhab принимает и отображает. Все работает.
С другими датчиками такой фокус пока что не возможен. Управлять розетками тоже пока нельзя.

6. Оповещение о нештатных ситуациях

Если температура выходит за пределы указанного диапазона, устройство делает соответствующую запись в лог, который также может дублироваться на внешний Syslog-сервер.
В последней прошивке NetPing-а разработчики добавили возможность использовать их Syslog-сервер, который в свою очередь может отправлять уведомления по электронной почте.
Когда я настраивал свою систему, такой опции еще не было, поэтому в качестве сервера на даче я использовал крошку Synology DS 411slim, для которого есть штатный сервер Syslog, который и присылает мне письмо в случае, если температура вышла за пределы указанного диапазона.
К сожалению, о пропадании/восстановлении интернета письмом узнать не удастся, так как запись в Syslog генерируется только в момент пропадания интернета, но не после восстановления связи.

Вместо Syslog-сервера, можно использовать SNMP Trap server. NetPing может, при выходе температуры за пределы указанного диапазона, отправлять TRAP, который можно обработать на сервере и запрограммировать соответствующую реакцию. Возможно, позднее попробую этот вариант, тогда вместо письма можно будет отправлять SMS (или и то и другое вместе).

7. Счетчик импульсов

На закуску расскажу об одной недокументированной возможности NetPing.
Предыстория: Расход воды на даче не очень регулярен, а фильтры в системе водоподготовки требуют плановой замены. Для того чтобы точно знать момент, когда пора менять фильтры, я установил счетчик холодной воды. А раз счетчик оснащен импульсным выходом, сразу зачесались руки его к чему-нибудь подключить…
Сначала я искал специализированные устройства, но те которые используются в ЖКХ, имеют закрытые протоколы и, как правило, стоят не разумных денег. Я уже было забросил затею подключить счетчик, как в голову пришла мысль: «А ведь у датчиков открытия/закрытия двери и у импульсного счетчика похожий принцип работы… Интересно, а NetPing запоминает количество открытий двери?»


«Разъединились половинки – уровень сигнала перешел из «0» в «1», соединились – снова вернулся в «0».»

Берем MIB Browser и смотрим, какие значения выдает NetPing:
>"/>
Параметр «.1.3.6.1.4.1.25728.8900.1.1.9.1» подозрительно похож на то, что нужно!
Подключаем счетчик воды по схеме датчика открытия двери…
>"/>
Ура! На каждый литр воды, счетчик действительно увеличивается на единицу!
Получить значение счетчика можно с помощью того же perl-скрипта, только делаем запрос сразу по нескольким oid:

Обратите внимание, что пока сервер выключен, перезагружается или просто занят более важными делами, ни один импульс не потеряется т.к., NetPing считает импульсы независимо от сервера!
Согласно документации к NetPing можно подключить до 4 аналогичных датчиков. Получаем простой вариант для квартиры: к одному NetPing можно подключить счетчики и горячей и холодной воды, а еще два входа останутся для датчиков протечки!

Заключение

Подведем итоги.
Плюсы:

  1. Стабильная работа 24/7 в течении 2 лет
  2. Отлично работающий режим «Сторож» для интернет-канала
  3. Две независимые розетки
  4. Коммутируемая нагрузка до 1кВт
  5. Встроенный Ethernet switch на 2 порта
  6. Возможность подключения различных датчиков
  7. Легкая интеграция с другими устройствами и системами

Минусы

  1. Неудобное подключение датчиков
  2. Низкая точность датчиков
  3. Немного путаная документация

В заключение хочу сказать, что доволен покупкой NetPing. Свою основную работу (перезагрузку роутера) он выполняет отлично. Ну а то, что удалось еще и как следует поразвлечься, находя ему дополнительные применения, я считаю прекрасным бесплатным приложением.

PS. Посоветуйте, плиз, аналогичное устройство, чтобы к нему можно было подключить (по возможности без паяльника) датчики избыточного давления, гидростатический датчик глубины и получить на выходе значения по SNMP или HTTP поверх Ethernet.

Данная статья не подлежит комментированию, поскольку её автор ещё не является полноправным участником сообщества. Вы сможете связаться с автором только после того, как он получит приглашение от кого-либо из участников сообщества. До этого момента его username будет скрыт псевдонимом.

Сейчас очень популярны так называемые умные устройства. В большинстве случаев основной их функцией является возможность дистанционного включения и отключения через интернет или мобильную сеть. Но также с помощью различных решений можно реализовать удаленное управление розеткой, соответственно и любым электрооборудованием. В этой статье мы рассмотрим способы решения этой задачи.

Виды связи

Дистанционное управление розеткой слишком широкая фраза, давайте конкретизируем как вообще можно это сделать:

Радиореле. Использование радиореле, обычно они работают на частоте 315 или 433 МГц. Этот вариант интересен тем, что позволяет встроить модуль как в устройство, которым вы будете управлять, так и в распределительную коробку. Радиореле бывают с разным количеством каналов и хорошим своей универсальностью и простотой реализации проекта в итоге. Недостатком является радиус действия.

Wi-Fi розетки и реле. Также просты в использовании и универсальны. На рынке много умных розеток, которые представляют собой переходник, устанавливаемый в обычную розетку, подобно таймеру или термостату. Недостатком является то, что нужна сеть вай-фай, но взамен во многих моделях вы получаете возможность удаленного управления не только через беспроводную сеть, но и через интернет, то есть с любой точки мира. Кроме того, производители предлагают модели с широким функционалом, типа учета электроэнергии, датчиков безопасности и прочего.

GSM-системы удаленного управления. Универсальное решение, но обычно отличается сложностью и высокой стоимостью. Позволяет управлять розетками удаленно через мобильные сети.

Для большей наглядности рассмотрим каждое из решений более подробно.

Радиореле

В зависимости от модели на плате устройства может располагаться 1, 2 и более реле, что позволяет организовать независимое дистанционное управление несколькими устройствами. Такие реле называются многоканальными (двухканальными или четырёх, например). Наиболее интересной особенностью таких реле является возможность их обучения (хотя этот факт зависит от конкретной модели). Это даёт возможность привязать к одному реле, несколько пультов радиоуправления которые работают на аналогичной частоте.

Вот так выглядит плата такого устройства. Черные прямоугольные элементы – это миниатюрные реле. Двойная клеммная колодка (ближе к нам на фото) предназначена для подачи питания. Встречаются реле с питанием от 220В, а есть и на 12В, при этом и те, и другие способны коммутировать нагрузку 220В – фактически это зависит от типа используемых реле. Клеммная колодка с 12 клеммами(слева) – это контакты самих реле.

Микровыключатель (кнопка в расположенная ближе к дальнему края платы на фото, слегка смещена вправо) нужен для привязки к новым пультам управления, когда оно в корпусе доступа к кнопке нет.

Как уже было сказано привязать можно любой пульт, даже не совсем пульт. Например, дверные радиозвонки часто работают на частоте 433 МГц. Чтобы узнать частоту передачи чаще всего нужно либо найти эту информацию на самом пульте, либо вскрыть его корпус и найти кварцевый резонатор – на нём и указана частота.

В этом видео наглядно показан процесс привязки пультов к реле:

Схема его подключения также проста: на вход подают фазу и ноль, а выходные контакты платы соединены с силовыми контактами реле. Обычно они рассчитаны на ток до 10, а иногда и до 20 А, что позволяет подключать нагрузку в 2 и больше кВт, хотя лучше это сделать через магнитный пускатель с катушкой на 220 В. В быту такое решение будет практичнее и долговечнее, особенно в контексте дистанционного управления розетками. Да и сложно представить реализацию нормальных дугогасительных камер в таких реле, скорее всего речь идет об активной нагрузке типа ТЭНов, но никак не об электроприводе.

Читайте также:  Водонепроницаемый пакет для телефона

Типовая схема подключения на примере включения лампочки изображена на рисунке ниже.

Здесь вы узнаете подробно о его подключении:

С помощью такого реле вы можете организовать управление светом из нескольких мест без сборки сложных схем и переделки проводки, а также подключить светильник несколькими группами ламп на два провода – фазу и ноль. Не стоит воспринимать это как панацею, скорее в приведенных примерах это способ решения, но не истина. Чем проще элементы схемы – тем она надежнее, а введение в цепи питания радиомодулей не упрощает цепь.

Если вам интересно мы сделаем более подробный обзор таких реле и покажем, как они работают на практике.

Умные розетки

Если опустить сложные системы управления через сотовую связь, то для среднестатистического человека проще купить готовое решение, которое требует минимума наладки при первом включении. Тогда следует рассмотреть так называемые умные розетки. Их можно разделить на две группы по типу управления:

Но в настоящее время привычка многих людей классифицировать не особо реализуема, потому что всегда есть смешанные типы, например, можно найти модели с поддержкой управления как по телефонной сети, так и по Wi-Fi. Также стоит отметить, что кроме этих стандартов применяются и менее распространенные в нашей стране:

В общем случае такая розетка представляет собой устройство, которое вставляется в обычную розетку, а уже в него подключается ваше оборудование. Конструкция аналогична тем приборам что мы рассматривали в статье Полезные дополнительные устройства в розетку

Такие переходники модно называют сокетами. Рассмотрим несколько моделей.

GSM-розетки

Для работы во все GSM-розетки нужно установить сим-карту. Это является основной проблемой этой группы устройств. Например, если розетка при «общении» с пользователем присылает СМС-ответы – тогда этот номер нужно регулярно пополнять, даже если эта функция не обязательна – то симку заблокируют через определенный оператором промежуток времени без пополнения счета.

SOKOL-GS1 – стоимость порядка 30 долларов. Производитель GEOS Electronics из Украины. Может коммутировать нагрузку до 3.5 кВт. Для управления розеткой вам нужно позвонить на СИМ-карту, установленную в прибор, вам ответит автоответчик, который даст вам сведения о состоянии прибора (вкл/выкл) и дать команды о включении или отключении нагрузки. Есть интересная функция «красный номер», её смысл заключается в том, что, если у вас телефон с двумя сим-картами вы можете назначить одну из них так, чтобы при звонке с неё независимо от состояния прибора приходил сигнал отключения нагрузки, а с «зеленого» номера – о включении.

interVision GSM SMART SWITCH (также известна как GSM-Switch SC1) стоит 45 долларов. Выдерживает нагрузку до 2 кВт. Для её включения нужно отправить SMS на установленный номер с содержанием SN0000ON или SN0000OFF. Подробную настройку вы увидите в этом видео.

Также интересна модель на 3 розетки.

Tesla Security GSM-POWER – модель за 85 долларов. Может коммутировать ток до 16А или 3.5 кВт мощности. В ней есть возможность подключения внешнего термодатчика и отправки SMS-сообщения на ваш мобильный телефон о температуре окружающей среды.

Также благодаря термодатчику устройство может работать как терморегулятор при управлении обогревателем и поддерживать установленную температуру. Возможно управление с 5 мобильных телефонов.

Computherm GSM158 розетка производителя из Венгрии. Стоимостью 95 долларов, она выдерживает нагрузку до 3 кВт. Возможность управления с 5 телефонных номеров (главный и 4 дополнительных). Можно задать работу по графику или так называемое интервальное включение (8 вариантов, типа с понедельника по пятницу, все дни или каждый день отдельно).

Wi-Fi розетки

TP-Link HS100 и TP-Link HS110 розетки с беспроводным управлением за 30 и 35 долларов соответственно. Отличаются эти модели тем что HS110 может следить за расходом электроэнергии за период времени и в данный момент.

Ею можно управлять либо с помощью кнопки в верхней части корпуса, либо через приложение, его нужно скачать с Play Market, если у вас Андройд или с AppStore для обладателей техники Apple.

С его помощью вы можете включать и выключать розетки или же задать им работу по сценарию. Также есть функция «Нет дома», она нужна если вы подключите источник света – он будет включаться и выключаться, имитируя ваше присутствие. Эта функция есть в большинстве подобных устройств.

Tesla SR16 – универсальное устройство за 21 доллар. Универсальность заключается в том, что она работает в качестве реле напряжения, таймера и управляется удаленно по сети Wi-Fi из любой точки мира.

Устройством управляют через WEB-интерфейс.

BroadLink Wi-Fi SP Contros за 25 долларов. Выдерживает ток до 16 А.

Для работы с ней нужно приложение e-Control. Оно есть в магазинах приложений Android и iOS.

Из функций доступно включение и отключение по требованию вручную нажатием на единственную кнопку на устройстве или со смартфона и задание расписания включений по таймеру. Также есть функция ночника.

Xiaomi Mi Smart WiFi Socket – умная розетка от производителя с мировым именем который выпускает качественную продукцию начиная от зубных щеток до электротранспорта. Её стоимость довольно демократична – всего 18 долларов, самая низкая стоимость из сегодняшней подборки. Выдерживает ток до 10 Ампер, что немного ниже большинства рассмотренных вариантов. Но и этого хватит для большей части бытовой техники – чайников, кофеварок и прочего.

На её корпусе, как и у предыдущих примеров есть всего одна кнопка. Для работы с устройством нужно скачать приложение управления системой умного дома от Xiaomi.

Недостатком этой розетки является то, что приложение частично на китайском языке. Но в интернете есть инструкция по его русификации. Возможно в скором времени выйдет полноценная официальная русификация. Функционал аналогичен предыдущим экземплярам – работа по расписанию и ручное управление. Для управления не нужно находится в одной сети с розеткой – работа происходит через интернет.

Wi-fi реле

Пожалуй, самой популярной моделью реле которым можно управлять по сети является продукт производителя Sonoff на официальном сайте его стоимость всего 650 рублей, на момент написания статьи — это почти 10 долларов.

Интересно это устройство тем, что позволяет управлять электрообрудованием удаленно, при этом обладает стандартным набором функций таких как ручное включение и управление по различным сценариям и таймерам.

Интересно также то, что есть модели с датчиками температуры и влажности, но такие устройства стоят уже немногим более 20 долларов. Сведения с датчика вы можете узнавать со своего смартфона. Они нужны не только для мониторинга, но и для программирования функций включения и выключения по заданным параметрам. Вся продукция работает под управлением приложения Ewelink для IOS и Android.

Вы можете прочитать более подробный обзор продукции в статье WiFi реле Sonoff world on — обзор устройств и примеры использования.

Заключение

Мы рассмотрели ряд способов организовать удаленное управление электрическими приборами с помощью реле и умных розеток, которые работают через мобильную связь (GSM) или через интернет (сеть Wi-Fi). При этом акцент был сделан именно на готовых решениях, которые требуют минимальных знаний и настроек. Более серьезный подход с установкой серверов и профессионального оборудования требует определённой подготовки и в разы больших финансовых вложений.

Системы удаленного управления электропитанием 220 вольт для включения или выключения оборудования представлены на рынке многими производителями, в том числе и отечественными – NetPing 2/PWR-220, Икар-ДУ, Aviosys IP Power 9258 S, Planet IPM-8002-EU. Но стоимость подобного оборудования достаточно высока, а функционал встроенного программного обеспечения очень низок. Все, что могут большинство решений – проверять на доступность адрес с помощью команды ping. Но в условиях реальной эксплуатации часто возникает потребность в более гибкой системе проверок работы оборудования и переключения каналов связи, что реализовать с помощью существующих на рынке устройствах невозможно.

Читайте также:  Что такое ламбрекены в армии

Программное обеспечение этих устройств не достаточно стабильное и иногда дает сбои, выраженные в виде самопроизвольного отключения нагрузки или зависаний, что не позволяет использовать их в труднодоступных местах.

Функционал операционной системы Mikrotik Router OS очень большой и стабильность работы хорошая, но в линейке оборудования этого производителя нет устройств управлением питания 220 вольт.

Если готовых устройств нет – можно сделать самостоятельно, на базе нового маршрутизатора со встроенным PoE коммутатором – Mikrotik RB750UP. Это совсем не сложно. При этом у созданного решения может быть одна, две, три или четыре управляемых розетки. Мощность 1500-2000 ватт на каждую.

Для сборки решения понадобятся следующие компоненты:

1.Блок питания 12 вольт – для запитывания устройства и реле.

2.Розетка – для подключения управляемой нагрузки.

3.Шнур питания – для подключения к сетевой розетке.

4.Автомобильное реле 75.3777 с колодкой – для управления питания нагрузкой.

5.Моток изоленты – для изолирования оголенных частей проводов.

6.Кусок кабеля витой пары – для подключения реле к микротику.

7.Mikrotik RB750UP – для управления.

Кабель витая пара с одной стороны обжимаем стандартным образом – БО, О, БЗ, С, БС, З, БК, К и подключаем к микротику. С другой стороны в разъем обжимаем только БО, О, БЗ и З. Синюю и коричневую пары разделяем и оголяем провода. Разъем можно использовать для подключения любого сетевого устройства.

Блок питания нужно использовать 12 вольт, 1 ампер или более мощный. Реле рассчитаны на напряжение 12 вольт. По этому нельзя применять блок питания на 24 вольта из комплекта поставки RB750U.

Сетевая розетка, в данном случае с возможностью установки на DIN рейку и заземлением. Под контакты удобно вставлять провода и зажимать специальными винтами. Купить розетку можно в любом магазине электротоваров.

Автомобильное пяти контактное реле 75.3777 и колодку к нему можно купить в автозапчастях. Спрашивать у продавца нужно – пяти контактное реле на 30 ампер с колодкой.

Из колодки выходят 5 проводов. На реле нарисована схема подключений.

Контакты 86 и 85 (черный и коричневый провод) используются для подачи питания на катушку реле, при этом происходит включение или отключение подключенной нагрузки по другим проводам.

Контакт 30 вводный, на него подается питающее напряжение нагрузки, красный провод.

Контакт 87 замыкающий, при включении реле на нем появится питающее напряжение, зеленый провод.

Контакт 88 размыкающий, при включении реле на нем пропадет питающее напряжение, желтый провод.

Обратите ВНИМАНИЕ – контакты на реле и на колодке отображены зеркально.

Синий и коричневый кабели витой пары соединяются к черному и коричневому кабелю колодки реле. С их помощью будет подаваться питание на электромагнитную катушку.

Красный кабель подключается к контакту в розетке.

К другому контакту розетки подключается подводящий кабель питания. В данном случае синий.

Второй провод от кабеля питания соединяется с желтым кабелем от реле. При этом во время включения реле будет происходить отключение подключенной к розетке нагрузки. Если нужно сделать наоборот – что бы при подаче питания на реле включалась и нагрузка, следует коричневый провод от подводящего кабеля соединить с зеленым проводом от реле. Но делать так не стоит, ведь при отключении питания устройства будет отключаться и нагрузка.

В итоге получилась следующая схема соединений. Все оголенные провода нужно замотать изоляционной лентой.

Для проверки работоспособности схемы собран не сложный тестовый стенд. В розетку подключена лампа, кабель питания подключен в сетевой фильтр, туда же и блок питания от микротика. Витая пара для управления розеткой подключена в 5-й сетевой порт, кабель управления в первый порт. Перед подачей питания проверьте еще раз надежность и правильность подключений.

При включении питания сразу загорается лампа – ведь питание на порту PoE отключено.

Это видно на Mikrotik RB750UP – горит только индикатор подключенного первого сетевого порта.

Теперь включаем на порту 5 питание PoE – лампа выключается.

На микротике загорается красный индикатор, сигнализирующий о том, что на 5-й порт подается питание PoE.

Видно, что управление питанием 220 вольт подключенной нагрузки работает должным образом.

Управление нагрузкой можно осуществлять в разделе INTERFACES в свойствах сетевого порта. Для этого в пункте PoE Out меняя значения On и Off включать и выключать питание. Установка значения Auto приведет к отключению питания порта, т.к. произойдет проверка подключенной нагрузки на соответствие режима пассивного PoE, которое реле не пройдет.

Управлять питанием порта можно и в окне терминала в разделе New Terminal.

Можно вводить следующие команды для управлением состояния порта:

/interface ethernet set ether5 poe-out=forced-on – для выключения нагрузки.

/interface ethernet set ether5 poe-out=off – для включения нагрузки.

/interface ethernet set ether5 poe-out=auto – в данном случае дано для ознакомления.

Кроме ручного управления питанием подключенной нагрузки, можно сделать автоматическую проверку доступности с перезапуском по питанию. Для этого в разделе SYSTEM—+SCRIPTS нужно создать новый скрипт в котором в поле Source ввести следующие команды:

# LANMART.RU 220v Script;

:local PINGCOUNT 5;

:local POEINTERFACE "ether5";

:log info message="START PING TO $PINGIP";

:local PINGRESULT [/ping $PINGIP count=$PINGCOUNT];

:if ($PINGRESULT > 0) do=<

:log info message="PING TO $PINGIP OK";

:log info message="PINGTEST $POEINTERFACE 220V OFF";

/interface ethernet set $POEINTERFACE poe-out=forced-on;

:log info message="PINGTEST $POEINTERFACE 220V ON";

/interface ethernet set $POEINTERFACE poe-out=off;

:log info message="PING TO $PINGIP END";

PINGCOUNT – количество отправляемых запросов для проверки доступности. Нужно устанавливать как минимум 5, что бы при случайных потерях не произошла не запланированная перезагрузка устройства.

PINGIP – сетевой адрес для проверки доступности. В нашем случае 10.0.0.11.

POEINTERFACE – сетевой интерфейс, к которому подключено контролируемое устройство. В нашем случае ether5. Указывать имя надо так, как назван интерфейс, большие и маленькие буквы считаются различными, и указав Ether5 ничего работать не будет.

Log info message – сообщения, которые добавляются в лог файл устройства, при выполнении скрипта.

Для запуска выполнения команд, с определенным интервалом, в разделе SYSTEM—+SHEDULER нужно создать новое расписание, нажав на +. В открывшемся окне нужно в пункте Start Time выбрать вместо времени – Startup. Тогда при включении устройства сразу начнется отсчет времени на запуск этого расписания. В пункте Interval указывается интервал запуска, указываем там 00:01:00 – то есть запускать раз в минуту.

В текстовом поле On Event указываем команду запуска созданного ранее скрипта:

После создания скрипта и запуска его в планировщике заданий, будет происходить автоматическая проверка подключенного устройства. Если оно вдруг станет не доступно по сетевому адресу – питание 220 вольт будет отключено и через некоторое время включено снова. Произойдет перезапуск подключенного оборудования.

Так же управлять устройством можно удаленно, например по Telnet или SSH.

Если нужно управлять питанием нескольких подключенных устройств – нужно собрать нужное количество реле с розетками и подключить к свободным PoE портам микротика.

Из Mikrotik RB750UP получилось многофункциональное устройство, которое может не только управлять питанием подключенных к ней устройств с помощью PoE, но и управлять питанием любых устройств, имеющих питание 220 вольт. При этом доступен весь спектр возможностей операционной системы Router OS. Разместить его можно в любом удобном корпусе.

Ссылка на основную публикацию
Adblock detector